Skip to main content
← All vulnerabilities
CVE-2024-58391GHSA-V248-PV3C-JVGW

Frappe before 15.4.0 XSS via Printview Parameters

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.58.0, 15.4.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Frappe before 14.58.0 and 15.x before 15.4.0 contains a cross-site scripting vulnerability in printview because printview parameters are not escaped before being rendered. Remote attackers can craft a malicious printview URL that, when visited by a victim, injects HTML and executes script in the victim's browser session.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • frappe frappe

    fixed in 14.58.0; From 15.0.0 · fixed in 15.4.0

References 2

GitHub · frappe/frappe

vulncheck.com