Skip to main content
← All vulnerabilities
CVE-2024-5816

Improper authorization allows persistent access in GitHub Enterprise Server

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a suspended GitHub App to retain access to the repository via a scoped user access token. This was only exploitable in public repositories while private repositories were not impacted. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.9.17, 3.10.14, 3.11.12, 3.12.6, 3.13.1. This vulnerability was reported via the GitHub Bug Bounty program.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitHub GitHub Enterprise Server

    From 3.10.0 · through 3.10.13; From 3.11.0 · through 3.11.11; From 3.12.0 · through 3.12.5; From 3.13 · through 3.13.0; From 3.9.0 · through 3.9.16

References 6

docs.github.com