CVE-2024-56412GHSA-Q9JV-MM3R-J47R
PhpSpreadsheet vulnerable to bypass of the XSS sanitizer using the javascript protocol and special characters
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: poc
- Automatable: no
- Technical impact: partial
Summary
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to bypass of the cross-site scripting sanitizer using the javascript protocol and special characters. An attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- PHPOffice PhpSpreadsheet
From 3.0.0 · fixed in 3.7.0; fixed in 1.29.7; From 2.0.0 · fixed in 2.1.6; From 2.2.0 · fixed in 2.3.5
- phpoffice/phpspreadsheetPackagist
From 3.0.0 · fixed in 3.7.0
- phpoffice/phpspreadsheetPackagist
fixed in 1.29.7
- phpoffice/phpspreadsheetPackagist
From 2.0.0 · fixed in 2.1.6
- phpoffice/phpspreadsheetPackagist
From 2.2.0 · fixed in 2.3.5
- phpoffice/phpexcelPackagist
through 1.8.2