Skip to main content
← All vulnerabilities
CVE-2024-56410GHSA-WV23-996V-Q229

PhpSpreadsheet has Cross-Site Scripting (XSS) vulnerability in custom properties

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 have a cross-site scripting (XSS) vulnerability in custom properties. The HTML page is generated without clearing custom properties. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • PHPOffice PhpSpreadsheet

    From 3.0.0 · fixed in 3.7.0; fixed in 1.29.7; From 2.0.0 · fixed in 2.1.6; From 2.2.0 · fixed in 2.3.5

  • phpoffice/phpspreadsheetPackagist

    From 3.0.0 · fixed in 3.7.0

  • phpoffice/phpspreadsheetPackagist

    fixed in 1.29.7

  • phpoffice/phpspreadsheetPackagist

    From 2.0.0 · fixed in 2.1.6

  • phpoffice/phpspreadsheetPackagist

    From 2.2.0 · fixed in 2.3.5

  • phpoffice/phpexcelPackagist

    through 1.8.2

References 2

GitHub · PHPOffice/PhpSpreadsheet