Skip to main content
← All vulnerabilities
CVE-2024-56365GHSA-JMPX-686V-C3WX

PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to unauthorized reflected cross-site scripting in the constructor of the `Downloader` class. Using the `/vendor/phpoffice/phpspreadsheet/samples/download.php` script, an attacker can perform a cross-site scripting attack. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • PHPOffice PhpSpreadsheet

    From 3.0.0 · fixed in 3.7.0; fixed in 1.29.7; From 2.0.0 · fixed in 2.1.6; From 2.2.0 · fixed in 2.3.5

  • phpoffice/phpspreadsheetPackagist

    From 3.0.0 · fixed in 3.7.0

  • phpoffice/phpspreadsheetPackagist

    fixed in 1.29.7

  • phpoffice/phpspreadsheetPackagist

    From 2.0.0 · fixed in 2.1.6

  • phpoffice/phpspreadsheetPackagist

    From 2.2.0 · fixed in 2.3.5

  • phpoffice/phpexcelPackagist

    through 1.8.2

References 2

GitHub · PHPOffice/PhpSpreadsheet