Skip to main content
← All vulnerabilities
CVE-2024-56199GHSA-WW33-JPPQ-QFRP

phpMyFAQ Vulnerable to Stored HTML Injection at FAQ

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

phpMyFAQ is an open source FAQ web application. Starting no later than version 3.2.10 and prior to version 4.0.2, an attacker can inject malicious HTML content into the FAQ editor at `http[:]//localhost/admin/index[.]php?action=editentry`, resulting in a complete disruption of the FAQ page's user interface. By injecting malformed HTML elements styled to cover the entire screen, an attacker can render the page unusable. This injection manipulates the page structure by introducing overlapping buttons, images, and iframes, breaking the intended layout and functionality. Exploiting this issue can lead to Denial of Service for legitimate users, damage to the user experience, and potential abuse in phishing or defacement attacks. Version 4.0.2 contains a patch for the vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • thorsten phpMyFAQ

    From 3.2.10 · fixed in 4.0.2

  • phpmyfaq/phpmyfaqPackagist

    From 3.2.10 · through 4.0.1

  • thorsten/phpmyfaqPackagist

    From 3.2.10 · through 4.0.1

References 1

GitHub · thorsten/phpMyFAQ