Skip to main content
← All vulnerabilities
CVE-2024-56144GHSA-2F4W-6MC7-4W78

Stored XSS-LibreNMS-Display Name 2 in librenms

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 24.12.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

librenms is a community-based GPL-licensed network monitoring system. Affected versions are subject to a stored XSS on the parameters (Replace $DEVICE_ID with your specific $DEVICE_ID value):`/device/$DEVICE_ID/edit` -> param: display. Librenms versions up to 24.11.0 allow remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. This issue has been addressed in release version 24.12.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • librenms librenms

    fixed in 24.12.0

  • librenms/librenmsPackagist

    From 24.11.10 · fixed in 24.12.0

References 1

GitHub · librenms/librenms